Page 2 of 2

Re: Playing Keen Mods In Web Browser

Posted: Thu Dec 14, 2017 0:12
by Commander Spleen
It actually does it in Linux too now, but somehow I hadn't noticed. Tried overriding Alt with JavaScript but it still triggers the menu.

Going to about:config?filter=ui.key.menuAccessKeyFocuses and changing it to false turns it off, but asking every user to modify their browser configuration is not an ideal solution.

Right clicking the toolbar and toggling Menu Bar on permanently shows the menu so the Alt is not intercepted, at least in Linux. If it also works on Windows then I'll suggest this as a workaround.

Still no idea what to do about Vivaldi apart from changing every mod's keyboard settings. It even captures Alt in fullscreen.

Re: Playing Keen Mods In Web Browser

Posted: Thu Dec 14, 2017 9:21
by Nisaba
I would strongly suggest to change every mod's keyboard settings! this can be done in multiple ways.
  1. via patching (I did this extensively for my CK-Handheld project:
  2. via an implemented mapper to configure game controllers (DOSBox does provide such tool, I don't know about yours)
the advantage of solution b) would be, that you could map multiple keys globally to all core keys needed. plus a number of keys could get assign in a way to trigger the same action. for eg.: [Strg] = jumping, [X] = jumping as well and so forth. plus factor of this solution is, that the player can decide which button layout to choose from. this way around, one can bypass browser specific issues; respectively use the well known key mapping if there is non button barrier.
other than that it might be a good idea to add a patch that prohibits two-button-firing in the Vorticons Universe. At least that's what I did to get things running with my GameBoyZero project.