Play My Duke Nukem 1 Mods in your browser!

Discuss classic and favorite computer or console games here.
Post Reply
Nickssoft
Vortininja
Posts: 98
Joined: Thu Nov 01, 2007 3:47

Play My Duke Nukem 1 Mods in your browser!

Post by Nickssoft » Tue May 03, 2011 21:44

http://nickssoftware.spatang.com/classic.htm

Finally updated my website so you can play my Duke Nukem 1 mods and other classic NicksSoftware games in your browser. All you need is Java for all games. Enjoy!


:dead2 Be sure to check out the homepage for information on our latest games we released.

User avatar
tulip
Flower Pot
Posts: 2520
Joined: Thu Aug 21, 2008 12:50
Location: Hamburg, Germany
Contact:

Post by tulip » Wed May 04, 2011 17:43

whoa nice, works pretty well it seems.

Just remembered that I couldn't use my standard keyboard setup, since 'S' which I use for jumping toggles the sound on/off...
Image You crack me up little buddy!

User avatar
RoboBlue
It's that one guy.
Posts: 911
Joined: Wed Apr 23, 2008 10:26
Contact:

Post by RoboBlue » Thu May 05, 2011 5:09

Wow, neat!
I've never played a duke 1 mod before, but this seems really fun.
Image

User avatar
Pokota
Vortininja
Posts: 129
Joined: Wed Apr 06, 2011 19:49

Post by Pokota » Thu May 05, 2011 13:19

@Tulip, you can still change the keybindings like normal.
There was something here, but my yorp ate it.

User avatar
_mr_m_
Vortimaestro
Posts: 423
Joined: Mon May 11, 2009 23:14
Location: A Midwest cornfield

Post by _mr_m_ » Tue May 10, 2011 18:54

This is useful for when I'm at work. Thanks
"I just drew this stupid little fish." -- Tom Hall

User avatar
DHeadshot
Vorticon Elite
Posts: 1874
Joined: Fri Aug 14, 2009 10:21
Location: UK
Contact:

Post by DHeadshot » Tue May 10, 2011 19:15

Put a warning next to any links to it (e.g. the homepage) that, since it uses Java, thanks to a bug in the more recent versions, if you try to use it on a browser implementing a variation of the Gecko2 engine (K-Meleon, FF2, a lot of versions of Opera, etc) it will crash your PC...
Cereal Board!
Deltamatic wrote:Prepositions are things I end sentences with.
(Cereal wiki has sadly died)

User avatar
TerminILL
Skypest
Posts: 589
Joined: Fri Oct 23, 2009 8:59
Location: In a box.
Contact:

Post by TerminILL » Tue May 10, 2011 22:11

That's really your own lookout for using an outdated browser. If there was a crash bug in, say, FF3/4 or Chrome (or maybe even IE, if you're feeling generous), it might be good practice to warn your users. However, there are a lot of good reasons to move beyond any of the outdated browsers you mention.
Shonikado wrote:Looking back on what we've done and wanting to change it is the first step in becoming a weakling that cannot do anything.

Nickssoft
Vortininja
Posts: 98
Joined: Thu Nov 01, 2007 3:47

Post by Nickssoft » Wed May 11, 2011 1:18

Im glad you guys are enjoying the games.

User avatar
kuliwil
Blue-tongued Yorp
Posts: 1731
Joined: Wed May 12, 2010 8:51
Location: Facestalking Commander Spleen.
Contact:

Post by kuliwil » Wed May 11, 2011 6:00

DHeadshot wrote:Put a warning next to any links to it (e.g. the homepage) that, since it uses Java, thanks to a bug in the more recent versions, if you try to use it on a browser implementing a variation of the Gecko2 engine (K-Meleon, FF2, a lot of versions of Opera, etc) it will crash your PC...
I suggest implementing a browser restriction in the webpage code prompting people to upgrade - saves pissing people off.
"Hi, I'm Tom Sellick's moustache."
Image

User avatar
DHeadshot
Vorticon Elite
Posts: 1874
Joined: Fri Aug 14, 2009 10:21
Location: UK
Contact:

Post by DHeadshot » Wed May 11, 2011 13:04

TerminILL wrote:That's really your own lookout for using an outdated browser. If there was a crash bug in, say, FF3/4 or Chrome (or maybe even IE, if you're feeling generous), it might be good practice to warn your users. However, there are a lot of good reasons to move beyond any of the outdated browsers you mention.
K-Meleon isn't outdated - it expands on the Gecko2 engine because the Gecko3 engine is still incredibly buggy and full of memory leaks. It runs at the same level as FF3.5, compensating for the engine deficiencies with its own code!
Cereal Board!
Deltamatic wrote:Prepositions are things I end sentences with.
(Cereal wiki has sadly died)

Post Reply