Page 1 of 3

Camoto Windows version

Posted: Sun Sep 29, 2013 13:06
by Malvineous
Hi all,

Just a quick post to let anyone who is interested know that I have finally released a version of Camoto that works under Windows. It's still a *long* way from being a practical tool for modding, but it might still have some uses all the same.

Here's the announcement and download link.

I'd be interested to know if anyone is actually able to get it to work - it doesn't seem to work as well under Windows for some reason! For those who aren't familiar with it, here's the list of games that can be edited:
  • Captain Comic
  • Catacomb
  • Catacomb II
  • Cosmo's Cosmic Adventures (incomplete)
  • Crystal Caves
  • Dangerous Dave
  • Dark Ages (no level editing yet)
  • Duke Nukem II (early stages)
  • Halloween Harry (incomplete)
  • Hocus Pocus (incomplete)
  • Jill of the Jungle
  • Monster Bash (incomplete)
  • Rockford
  • Secret Agent (no level editing yet)
  • Wacky Wheels
  • Word Rescue
  • Xargon (incomplete)
  • Zone 66 (music only, incomplete)
Image Image Image

Posted: Sun Sep 29, 2013 16:57
by troublesomekeen
Oh my. I'm running on Windows Vista.
I opened up Word Rescue 1 and...well.. it works:


Dat is amazing.

Posted: Sun Sep 29, 2013 19:07
by Pokota
I tried opening up Jill of the Jungle and it's saying it's missing jjfile1.exe

Also, the installer is showing up as a virus according to Avast. You may want to look into that.

Posted: Sun Sep 29, 2013 19:26
by Roobar



For some reason I'm able to edit only your mod, not the original game. When I load the original Crystal Caves 1, it opens the hierarchy, but some strange things happen. Anyway. I'm still trying to figure out how the things works and I cannot understand how to change the backgrounds and how to tell and change which level is which in the world map.

Posted: Sun Sep 29, 2013 20:43
by Malvineous
Glad to hear it's working! It's nice to see some screenshots proving it too :-D

If you're missing jjfile1.exe it just means you have an incomplete version of the game, but it shouldn't prevent you from editing anything. The virus thing is a bit worrying though... I ran it through Avast on but it came back ok, maybe your virus definitions are out of date?

I forgot to mention that there is no built-in unlzexe support yet, so those games that store data in the .exe file need to have unlzexe run manually. Just go into your project directory, into the "data" subfolder, and run unlzexe on the .exe file. This should get Crystal Caves and a few others working.

With Crystal Caves, have a look at the page on the ModdingWiki which has some tips about the doors etc. The backgrounds aren't editable yet as it requires patching the .exe like with CKPatch, only there's no equivalent for CC yet.

Posted: Sun Sep 29, 2013 20:59
by NY00123
Although I have not really gotten into editing a lot of games that often...

After a long time Camoto could be tested, mostly on a non-Win platform, finally an initial Windows release is out!

Regarding the virus, there are chances it is a false positive, especially if the EXE is compressed with a tool like UPX. In case of doubts it is still safer to check that there is truly no virus, though.

Posted: Sun Sep 29, 2013 21:32
by Malvineous
Definitely no virus, it was built in a clean VM with no external network access. The 50 or so scanners at all came back clear, so it's definitely a false positive.

The .exe isn't compressed, but of course all the files in the installer are so I guess something there triggered it.

Posted: Sun Sep 29, 2013 23:51
by Pokota
Not sure how I have an incomplete version of Jill of the Jungle when I have the non-Shareware version. And yes, it prevents me from editing everything.

In fact, this error message was the first time I'd ever heard of jjfile1.exe - I'll grab unlzexe and see what turns up with that.

Posted: Mon Sep 30, 2013 5:58
by Levellass
I don't like its style, but I am awed by its functionality.

Posted: Mon Sep 30, 2013 9:50
by Malvineous
Anything in particular you don't like about the style? I'll admit it's pretty basic, but to be honest most of the effort so far has gone into the file formats rather than the UI.

I've checked my copy of Jill. jjfile0.exe is the episode selection screen, jjfile1.exe is the first episode, jjfile2.exe is episode 2, and jjfile3.exe is episode 3.

I have seen a few different versions of Jill floating around, so you may have one of the other ones? What .exe files do you have in yours? Where practical I have tried to support multiple versions but generally it comes down to supporting the latest one only. However Jill editing is still a bit iffy - the file format is shared with Xargon and I think there is code in there at the moment that causes problems for Jill. You might have to stick with Jill's built in level editor for the time being (press Ctrl+E on the main menu.) Hopefully I'll have this fixed for the next release.

Posted: Mon Sep 30, 2013 19:44
by _mr_m_
Works great with Wacky Wheels. Haven't tried to edit any levels yet, but I can at least read all the tilesets and levels...including an unused tileset (might try to make a modded map with it)


Zone 66 on the other hand, doesn't seem to work just yet. Here's the error I get trying to open any of the tilesets/levels:


Posted: Tue Oct 01, 2013 5:33
by Levellass
Malvineous wrote:Anything in particular you don't like about the style? I'll admit it's pretty basic, but to be honest most of the effort so far has gone into the file formats rather than the UI.
It's because I've been spoiled with modkeen like UIs which are flexible and well developed. As you note Camtoo is wide ranging but not that deep.

Posted: Tue Oct 01, 2013 7:59
by Malvineous
Yeah Zone 66 is definitely a work in progress...

I didn't realise ModKeen had a UI? I thought it was a command line program?

Or, if you mean you prefer the command line interface, then take a look in the Camoto installation folder. There are six other .exe files in there which are command-line interfaces to the same underlying code that the GUI uses. The command line programs actually have quite a bit more functionality, like for example the "gamearch" program which manipulates archive files - these are things like Duke3D .GRP files, Monster Bash .DAT, Cosmo .VOL, etc. gamearch can list, extract, overwrite, rename, reorder and delete files inside these archives, which can't be done through the GUI.

Likewise the "gametls" program can export and import tilesets, similar to ModKeen's command-line interface. You can export an entire tileset into a single .png image, or export single images to in

These are the six commands available. Each link below goes to the manual page explaining the command line syntax (probably best to skip to the end and read the examples first.) Running each command with the --help parameter will also give a brief summary.
  • gamearch.exe - View and edit group/archive files
  • gamecomp.exe - Encrypt/decrypt and compress/decompress individual files
  • gametls.exe - Extract (as .png), view (in ANSI/ASCII) and replace images within a tileset (a tileset is a single file containing many images)
  • gameimg.exe - View (in ANSI/ASCII) and replace single-image graphics files
  • gamemap.exe - Examine game levels (hex dump, print metadata)
  • gamemus.exe - Import, export and basic conversion of game music files

Posted: Tue Oct 01, 2013 17:10
by Nickssoft
can somebody make Alien Carnage Level maps out of this? cool!

Posted: Tue Oct 01, 2013 17:26
by MoffD
When I open HHH with it, it only appears to open the "screens" and the objects are unknown, is this just because it isn't entirely supported?