Audio Problems with HQ in Windows 10

All discussion about the Commander Genius project (a Keen interpreter + more).
Post Reply
Jeff
Grunt
Posts: 5
Joined: Mon Nov 26, 2018 17:24

Audio Problems with HQ in Windows 10

Post by Jeff » Mon Nov 26, 2018 17:36

Hi, I've been working on getting my Steam complete pack games working with Commander Genius with the hq pack, under Windows 10. The games run fine, but music is not playing, apparently a problem loading ogg files (which play fine when I use them with vlc, for example). Log file for keen 2 shows:Mix_LoadMUS("E:\CGenius/global/music/keen2map.ogg"): Unrecognized audio format. I get similar entries after running other games, with no music. Any ideas about this?

Thanks :garg

gerstrong
Vorticon Elite
Posts: 1143
Joined: Wed Dec 31, 2008 14:44
Location: Frankfurt - Germany
Contact:

Re: Audio Problems with HQ in Windows 10

Post by gerstrong » Wed Dec 05, 2018 6:22

Strange. I don't think it is Windows 10 related. Might be Windows in general...

Let me check what this is about. Seems to be related to SDL_Mixer and libogg DLLs.

What you can do is change those DLLs, but better let me take a look...

I wanted to build another release in a couple of days anyways...
Having fun developing stuff...

gerstrong
Vorticon Elite
Posts: 1143
Joined: Wed Dec 31, 2008 14:44
Location: Frankfurt - Germany
Contact:

Re: Audio Problems with HQ in Windows 10

Post by gerstrong » Fri Dec 07, 2018 17:42

Hi, I have uploaded another Release,

https://sourceforge.net/projects/clonek ... nius/V2.2/

I hope it helps. I bundled more dlls. Testing it on my system here all the ogg-files play fine.

Let me know if it solves the problem on your side.
Having fun developing stuff...

Jeff
Grunt
Posts: 5
Joined: Mon Nov 26, 2018 17:24

Re: Audio Problems with HQ in Windows 10

Post by Jeff » Sun Dec 16, 2018 18:51

Yep, that seems to have fixed it, music is working fine. Thanks for the effort.

Jeff

Post Reply